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Download Fortis Test Protocols and Test 
Files 

The .zip file contains the test protocols below along with the test files referenced in 
them.  

Media:Fortis Test Protocols.zip  

Media:Fortis Test Protocolsv1.0.pdf Note: does not include testing files, main document 
only  

Testing Protocols for Fortis Revolution 

These Sample Projects are meant to exploit all of the functionality in Fortis Revolution. 
The tasks may at times seem repetitive, but the reason for that is three fold:  

1. We believe that familiarity with Fortis will increase work efficiency.  
2. We are always searching for ways to improve Fortis so that it will become a tool 

that translators love to use.  
3. We desire to continue to find and fix bugs, in order to refine our code base.  

Our next great desire as the Multiling Development team is that users would develop 
and submit their own protocols to further user-support, and development efforts.  

Simple Test Scenarios 

This set of protocols is deigned to help you test and get acquainted with the basic 
functionality of the Fortis Revolution Editor.  

Preparation 

1. Open a Windows Explorer Window.  
2. Select your C:/ drive. For most users, this will be the default drive.  
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3. Right-click in the Explorer window.  
4. Select New > Folder from the right-click menu.  
5. Name the folder development.  
6. Copy the Fortis Test Files into this new folder.  

N.B. You may use a different drive if you choose, but I will make consistent reference to 
the C:/development/ folder throughout the Fortis Revolution Test Protocols.  

Check Profile Settings  

1. Open Fortis Revolution.  
2. Select Options > Profile Settings  
3. In the Preferences tab you can set your Profile Name, User Name, and initials.  
4. Click on the Editor tab.  
5. From this tab you can change the background and text colors for different text 

types in Fortis Revolution. Leave the default settings for now.  
6. Click the Fuzzy tab. The Fuzzy Threshold in the Profile Settings dialog sets the 

minimum match requirement for the segments that will be included in the 
assoref files. Leave the Threshold at the default value (70%) for now.  

7. Click Save to keep any changes you made to your Profile.  
8. Click OK to close the Profile Settings dialog.  

Project Settings 

This is one of the most heavily trafficked dialogs in Fortis Revolution, and one with 
which you will likely become very familiar.  

1. Go to Options > Project Settings. The Project Settings dialog should 
appear.  

2. You should be at the Project tab. This tab contains project particulars, language 
settings and the dictionaries is use.  

3. The Working Folder is the default browse location for this project. Click the 
Browse... button and choose C:\development\SimpleFile. The Language 
Settings are broken into groups, Source and Target. Many languages have 
variants which are under Region.  

4. Set the Source to English, and Region to United States.  
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5. Set the Target to Russian, and Region to Russian Federation. You have now set 
your working folder and language settings.  

If you suspect any of these features did not perform as described, explain the problem, 
the steps to recreate the problem, and the results on the Multiling Trac website.  

This is sufficient to continue with this test scenario. We will use the rest of the Project 
Settings dialog in the next test scenario. Click OK to accept the changes you made to 
this project definition and exit the Project Settings dialog.  

Open File 

1. Still in the Fortis Revolution main editor window, click on File > Open 
Language Pair  

2. The browser should open to your working directory, 
C:\development\SimpleFile. Click on Fire_and_Ice_en.fff. The file name 
should appear in the 'File name' text box.  

3. Click Open  
4. The language pair for Nothing Gold should open in the Fortis Editor. The window 

layout you chose in Project Settings should be displayed here. The Source 
window should contain the original English text, and the Target window should 
contain a copy of the Source text. Some of the segments should be blue, and their 
segment numbers should have a plus mark after them.  

Editor Views 

1. With the language pair still open:  
2. Click Window and hover the mouse over Arrange Windows  
3. A submenu that contains the numbers 1-5 should drop down.  
4. Choose window layout 1. If the Fortis editor windows are not already in 

arrangment 1, they should shift to the arrangement 1 default.  
5. Choose each of the window arrangement options in turn. The window layout 

should change with each selection.  
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N.B. Choosing the window arrangement from this menu will affect the window 
arrangement for this translation session only. To change the default arrangement, you 
need to make the change in the Profile Settings dialog.  

Fonts 

1. Click Options > Codepages\Fonts  
2. Fortis Revolution allows you to assign separate fonts to separate scripts. Any 

languages not specifically designated will use the font defined in Common.  
3. Double-click Common. Another window should appear. It contains a font drop 

down menu that is populated from your system fonts. If you need fonts that are 
not displayed in the list, make sure that they are installed on your system first.  

4. Choose 'Bookman Old Style', and click OK to close the window.  
5. Click OK in the Font Selection dialog to accept your change.  
6. Close the language pair by going to File > Close.  
7. Reopen the language pair by using File > Open Language Pair. The font change 

should be reflected.  

N.B. When characters are not rendering properly, it is most likely a font selection 
problem. Choose a font that supports the intended characters and reopen the language 
pair. Other solutions may be found on our FAQ page.  

Text and Background Colors 

1. Open the Fire_and_Ice file pair.  
2. Click Options > Profile Settings.  
3. Click the Editor tab.  
4. The bottom half of the dialog box should contain one empty text box to the left of 

Color..., and a larger scrolling text box to the left of Background. The scrolling 
text box should show several boxes with colored dots in the middle. To the right 
of the colored boxes and dots, the text type is defined. The color settings you see 
are the default settings that are loaded upon installation. From this tab, the editor 
colors are customizable.  

5. Click Text. The word Text should appear in the blank text box.  
6. Click Color... and select the fourth color down on the far left hand side.  
7. Click OK.  
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8. Now click Apply in the Profile Settings dialog box. The main text should 
appear as the color you selected.  

9. Scroll down the list of text options until you come to Active Segment. Select it 
and click Background.  

10. Select the third color down in the second vertical row. It should be a dark orange 
color.  

11. Click OK to accept the changes in the Color dialog and Apply in the Profile 
Settings dialog box to activate your changes.  

12. Click Save in Profile Settings to permanently keep these settings.  
13. Click around on a few different segments. The segments you choose should have 

the brown text and orange background you selected.  
14. You may repeat the instructions above and choose a color scheme that makes 

Fortis Revolution comfortable for you.  

N.B. You can create a custom color palate by selecting Add Custom Colors >> from 
the Color dialog.  

Cursor movements 

1. With the current file pair still open, click between 'see' and 'me' in the middle of 
the fifth segment. The cursor should blink there until you take further action.  

2. Press the Up Arrow. The cursor should move up one line.  
3. Press the Down Arrow. The cursor should move down one line, and be back in its 

original position in the fifth segment.  
4. Press the Right Arrow. The cursor should move one position to the right for each 

press.  
5. Press the Left Arrow. The cursor should move one position to the left for each 

press.  
6. Press the Plus (+) key on the keypad. This will advance the cursor to the next 

segment.  
7. Press the Minus (-) key on the keypad. This will move the cursor to the previous 

segment.  
8. Put the cursor in the middle of segment ten and press Home. The cursor will 

move to the beginning of the current line.  
9. Now press End. The cursor will be at the end of the current line.  
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10. Put the cursor back in the middle of the segment and press Enter. The cursor will 
be on the new line with the second half of the segment.  

11. Press ALT+Left Arrow. Even though the segment spans more than one line, the 
cursor will move to the beginning of the segment.  

12. Press ALT+Right Arrow to move to the end of the segment.  
13. Move back to the beginning of the segment, and press Page Up. This will move 

the cursor to the top of the current display window. Pressing Page Down will 
move the cursor to the bottom of the viewable window.  

14. Pressing CTRL+Home will move the cursor to the beginning of the file, and 
CTRL+End will move to the end of the file.  

15. Press Page Up once to move the cursor to the top of the window. Pressing it again 
will shift the view up one screen.  

16. Pressing Page Down once will move the cursor the end of the screen. Pressing it 
again will shift the view down one screen.  

17. Put the cursor in the middle of segment ten again. Press CTRL+Left Arrow. The 
cursor will move to the beginning of the word if it was in the middle of a word, or 
to the beginning of the preceding word if it was in between words.  

18. Pressing CTRL+Right Arrow will move the cursor to the following word.  

Text Block Manipulation and Some segment shortcuts (next untr. seg.) need to be 
demonstrated with another file.  

Hide/Display Tags 

Fortis Revolution protects the formatting information in a document by inserting tags. 
Full tags are the default display option and are write-protected by default, to prevent the 
user from inadvertently disturbing the formatting information. To make the tags less 
obtrusive, however, you can hide tags, or display portions of them.  

1. Click on the Target window to make sure it is the active window  
2. Click View > Tag Settings. The Tag Settings dialog box will appear. You will 

see two sets of three radio buttons. The buttons next to Formatting/font Tags 
will change the settings for all of the formatting tags. The Segment Limit Tags 
will change the settings for the segment markers.  

3. Under Formatting/Font Tags click Show First Character of Tag and then 
OK. All of the formatting tags should be displayed as a left angle bracket.  
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4. Go back to the Tag Settings dialog. Select Do Not Display Tags, and click OK. 
Only the segment tags will be visible at this point, since all of the formatting tags 
are being hidden.  

5. To display the formatting tags, go to the Tag Settings dialog and select Display 
Full Tags.  

6. Follow the same steps under the Segment Limit Tags heading to change the 
segment tag settings. When you select “Show First Character of Tag”, only the 
first curly brace of each segment limit will show. The segment numbers will be 
hidden. Select “Display Full Tags” to restore the segment numbers.  

7. The tags for the Source and Target windows must be set individually. Follow the 
same steps for the Source window as you did for the Target window.  

Cut 

1. In segment seven, highlight the word 'without' in the target window.  
2. Go to Edit > Cut. 'Without' will disappear, and be stored in the clipboard.  

Paste 

1. Leaving the cursor where it is, click Edit > Paste. 'Without' will be inserted in its 
original location.  

Copy 

1. Highlight all of the text, excluding the tag, in segment 7.  
2. Click Edit > Copy in the Menu bar.  
3. Put the cursor at the beginning of segment 9. Click Edit > Paste.  
4. Segment 7 will remain in its original position, with a copy of segment 7 pasted in 

front of segment 9.  

Buttons for these Edit functions exist on the toolbar. Now that you know where these 
Edit functions are in the menu, you may feel free to use them from either the menu, or 
the toolbar.  

Find & Find Next 
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1. Place the cursor at the beginning of the document in the target window.  
2. Click Edit > Find. Type 'ice' into the Find what field. Leave the other settings 

at their default values for now.  
3. Click OK.  
4. The first item that should be highlighted is 'Ice' in segment 2.  
5. Click Edit > Find Next. Use the toolbar button to continue using 'find next' 

through the rest of the document. 

The rest of the highlighted elements are (in order):  

o The whole word 'ice' in segment 4.  
o 'ice' as part of the whole word 'twice' in segment 9.  
o The whole word 'ice' in segment 11.  
o 'ice' as part of the whole word 'suffice' in segment 13.  

After Fortis has displayed these results, you will see a pop up box that says, ""ice" 
was not found."  

6. Click OK.  

Replace 

1. Place the cursor anywhere in the document.  
2. Click Edit > Replace.  
3. Type 'i' in the 'Find what' box, and 'EYE' in the 'Replace with' box.  
4. in the 'Search' section, select All. (By default Fortis searches a document from the 

cursor position to the end of the document. Selecting All causes the search to 
wrap around the document, and end at the original cursor position.)  

5. Leave the other settings at their default values for now.  
6. Click OK.  
7. When the Confirm dialog pops up, click All, to change all tokens of i to EYE. 

Segnments 6-13 should look like this:  

From what EYE've tasted of desEYEre<@BR>{6}  
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EYE hold wEYEth those who favor fEYEre.{7}  

<@BR>{8+}  

But EYEf EYEt had to perEYEsh twEYEce,<@BR>{9}  

EYE thEYEnk EYE know enough of hate<@BR>{10}  

To say that for destructEYEon EYEce<@BR>{11}  

EYEs also great<@BR>{12}  

And would suffEYEce. {13}  

8. Perform another Find and Replace to change all of the 'EYE's back to 'i's.  

Save 

1. Click on File > Save. This will overwrite the old file with the same information 
you see in the Fortis editor windows.  

Close File Pair 

1. Click File > Close to close the active file pair.  

N.B. If changes have been made since the file was opened, Fortis Revolution will prompt 
you to save changes before closing the file pair.  

Reset Project Settings 

1. Hover your mouse over each of the toolbar buttons in turn. A text box with a 
short description of the button should appear as long as you hover the mouse 
over a button.  

2. Find the button that says "Open Project Settings Window". Click on it. The 
Project Settings dialog should appear. Up until now we have been using the 
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menu bar to access all of the Fortis dialogs. Now we will begin to make you 
familiar with the toolbar.  

3. The Profile tab should be the active tab. Leave our Source language alone, but 
set the Target language to French and Region to Canada.  

4. Leave the Project Settings dialog box open for the next protocol.  

Browse to Working Folder 

1. Click the ... button next to the Working Folder text box. The Browse For 
Folderdialog box will pop up, showing the file structure of your computer.  

2. Browse to c:/development/SimpleFile/shallow/medium/deep.  
3. While the /deep subdirectory is highlighted, click OK to keep this change and 

return to the Project Settings dialog box.  
4. The new Working Folder path should be displayed in the Working Folder text 

box.  
5. Click Save and OK to save your changes and close the project Settings dialog box.  

Simple Import 

1. Click File > Import Documents  
2. Look at the “Select Files to Import” section. There are two buttons at the end of 

the text box. They behave as follows:  
o Sheet with a turned down corner – lets you select a single file to import.  
o Opened folder – allows you to import the contents of a folder or directory.  

3. Click the File Button on Select Files to Import.  
4. The Open File dialog should pop up and open directly to the working folder. 

Select Stopping_By_The_Woods.doc.  
5. Fill out the import dialog as follows:  
6.   Select files to import: 
7.   c:\development\SimpleFile\shallow\medium\deep\Stopping_By_The_Woods.doc" 
8.   [ ] include subdirectories 
9.    
10.   Select location to save imported files: 
11.   .// 
12.   [x]  save an import log:  
13.   simple.log 
14.    
15.   Select Actions:  
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16.   [x] Filter 
17.   [ ] Convert 
18.   [x] Segment 
19.   [x] Pretranslate 
20.   [ ] Extract 
21.    
22.   [ ] enable multilanguage import 

23. Press the Import button, and wait for the import to complete.  
24. Verify that the following files have been created (all should be in the working 

directory):  
o Stopping_By_The_Woods_en.fff, Stopping_By_The_Woods_fr.fff, 

Stopping_By_The_Woods.cod  
o simple.log.  

Any missing or other additional files indicate a bug.  

25. Click Cancel to close the Import  

Change Working Folder-Paste in File Path 

1. Open a Windows Explorer window and navigate to 
c:\development\SimpleFile\shallow\medium.  

2. Highlight the file path in the address bar.  
3. Right click and select Copy.  
4. In Fortis Revolution, click File > Import Documents.  
5. Click the Project Settings… button at the bottom of the dialog box.  
6. In the Project settings window, paste the file path you copied from the Windows 

Explorer address bar into the Working Folder text box.  
7. Click Apply, then OK.  
8. Click Cancel to close the Fortis Import dialog box.  

Simple Import, saving an Import Log to an Alternate Location 

1. In the c:\development\ directory create the subdirectory 'log_files'  
2. Open the Import Documents dialog.  
3. Select Fire_and_Ice.doc in the working directory. The directory should 

contain no other files.  
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4. Make sure that the 'Save an Import Log' box is checked.  
5. Name the log 'simple.log'.  
6. Fill the import dialog out as follows:  
7.   Select the files to import:  
8.   c:\development\SimpleFile\shallow\medium\Fire_and_Ice.doc 
9.   [ ] include subdirectories 
10.    
11.   Select location to save imported files  
12.   c:\development\SimpleFile\shallow\medium 
13.   [x]  save an import log:  
14.   c:\development\SimpleFile\log_files\simple.log 
15.    
16.   Select Actions:  
17.   [x] Filter: Microsoft Word 2003 
18.   [ ] Convert 
19.   [x] Segment: Word2003, by sentences 
20.   [x] Pretranslate 
21.   [ ] Extract 
22.  
23.   [ ] enable multilanguage import 

24. Press the import button, and wait for the import to complete.  
25. Verify that the following files have been created (all should be relative to the 

working directory):  
o Fire_and_Ice_en.fff, Fire_and_Ice_fr.fff, Fire_and_Ice.cod.  
o projects\log_files\simple.log  

26. The only additional files should be the original Fire_and_Ice.doc. Any missing or 
other additional files indicate a bug.  

Change Working Folder-Drag in File Path 

[Feature not currently supported]  

Simple Import with Reference 

1. Set the Target language back to Russian.  
2. Set the Working Folder to c:\development\SimpleFile\shallow.  
3. While still in Project Settings, go to the PreTrans tab.  
4. In the Reference Memories section, click Add... and browse to 

c:\development\SimpleFile\Frost_Reference.  
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5. Click OK  
6. The Frost Reference File Path should now show up in the Reference 

Memories section.  
7. Click OK.  
8. Import Nothing_Gold.doc. The Import dialog should look like this:  
9.   Select the files to import: "c:\development\SimpleFile\shallow\Nothing_Gold.doc" 
10.   [ ] include subdirectories 
11.    
12.   Select location to save imported files: "c:\development\SimpleFile\shallow" 
13.   [x]  save an import log: "simple.log" 
14.    
15.   Select Actions:  
16.   [x] Filter: Microsoft Word 2003 
17.   [ ] Convert 
18.   [x] Segment: Word2003, by sentences 
19.   [x] Pretranslate 
20.   [ ] Extract 
21.  
22.   [ ] enable multilanguage import 

23. Click the Import button and wait for the Import to complete. You should notice 
that the import takes a little bit longer. That is because Fortis needs to build the 
Fuzzy Network - a system which indexes and compares the information in you 
Reference Memory against the document you are importing.  

24. Examine the import log. All zeroes indicate an import error. Check for non-zero 
numbers.  

25. You should see an 'assoref' file for each half of the language pair along with the 
language pair and the .cod file. Any extra or missing files indicate a bug and 
should be reported on the Multiling Trac website.  

A Note About Reference Memory Files 

Fortis Revolution uses pretranslated language pairs as memory. In the previous 
task, you selected a Reference Memory location. The folder you selected 
contained portions of the poem that had already been translated. Fortis 
Revolution will use that folder and recursively search any subfolders within that 
folder to find file pairs. We recommend keeping an organized folder of your 
translated work so that you can leverage as much of you work as possible. This is 
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where Fortis becomes an indispensable tool for increasing your translation 
efficiency.  

Open Language Pair 

1. Find the Open File Pair button in the toolbar and click it.  
2. The Open Language Pair dialog box should open to the working directory.  
3. Select Nothing_Gold_en.fff and click Open. When you open the file, you will 

notice that the majority of this file is blue and that the segment tags have a plus 
sign (+) after the segment number. This indicates that the segment was 
pretranslated, or, had a 100% match in the Reference Memory.  

Begin Fuzzy Network with ALT+INS 

1. Place your cursor anywhere in segment one and press ALT+ENTER. This will 
start the fuzzy engine, and show any fuzzy results for the active segment.  

2. Segment one should show a 99% match (percentage visible at the bottom of the 
Fuzzy Translation suggestion in the Fuzzy Network Window).  

Insert Fuzzy Translation 

1. Double-click on the suggested translation, and it should appear in segment one of 
the Target window.  

Mark Active Segment as Translated 

1. With segment one as the active segment, press ALT+INS. The segment will be 
highlighted in green, an asterisk (*) will appear after the segment number, and 
the next translatable segment will become the active segment.  

A green background is the default color for manually translated segments, and 
the asterisk is the segment tag indicator for a manually translated segment.  

Fortis will also automatically query the fuzzy network for the next translatable 
segment. (If there is a fuzzy match for segment twelve, it will be displayed in the 
Fuzzy Network window.)  
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Simple Export Test 

1. Make sure that The file pair, the assoref files, the extract files, the original 
document and the four tran files (transfiles, transindex, transmatrix, and 
transsegment) are the only files in the working directory.  

2. Click File > Export Documents. The Fortis Export dialog will appear.  
3. In Select files to export, choose Nothing_Gold_ru.fff  
4. Fill the export dialog out as follows:  
5.   Select files to export: "c:\development\SimpleFile\shallow\Nothing_Gold_ru.fff" 
6.   [ ] include subdirectories 
7.   Select location to save exported files: "c:\development\SimpleFile\shallow" 
8.   Select Actions: [x] Desegment 
9.   [ ] Convert encoding to CYRILLIC 
10.   [x] Export: Microsoft Word 2003 

11. Press the export button, and wait for the export to complete.  
12. Verify that Nothing_Gold_ru.doc has been created. The only additional files 

should be those mentioned in step one. Any missing or other additional files 
indicate a bug.  

Review Language Pair 

1. Open a Windows Explorer window and go to 
c:\development\SimpleFile\shallow.  

2. Double-click Nothing_Gold_ru.doc. This is the product of the export you just 
did.  

3. Verify these parameters in the new document:  
o The entire text is black.  
o The text is left-justified.  
o The Title is size 18 Times New Roman font.  
o There is a blank line in between the title and the beginning of the poem.  
o The main body of the poem is size 12 Times New Roman font in italics.  
o There is a blank line in between the end of the poem and the last line.  
o The last line of the poem is in English, and says "Nothing gold can stay".  
o The last line (which is 'Robert Frost' in Cyrillic characters) is in size 12 

Times New Roman font (no italics).  
4. Any departures from these parameters should be reported to the Multiling 

Development Team.  
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Multiple Files Scenario 

Create new Profile 

1. Click on Options > Switch Profile.  
2. Select <Create New Profile…> and click OK.  
3. Enter “MultiTest” as the New Profile Name and click OK.  
4. Use the Profile Settings toolbar button to bring up the Profile Settings 

dialog.  
5. First, check the Profile Path at the bottom of the Profile Settings dialog. It 

should end in “MultiTest.prf”.  
6. At the top of the Preferences tab, type in the Profile Name “Multiple”, User 

Name “Multi”, and User Initials “MPL”.  
7. Under the Fuzzy tab, uncheck the Translate 100% Matches Automatically 

box.  
8. Save your new profile by clicking the Save button.  
9. Click OK to close the window.  

Switch Profiles 

1. Go to Options > Switch Profile.  
2. Select "Multi.prf" from the Switch Profile menu and click OK.  
3. Check the Profile Path in the Profile Settings window to make sure that the 

proper profile is loaded.  

Create new Project Definition 

1. Click Options > Switch Project.  
2. Select <Create New Project…> and click OK.  
3. Enter “Multi-Frost” in the New Project Name and click OK.  
4. Open the Project Settings dialog.  
5. Set the working folder to c:\development\MultiFile.  
6. Make sure that the target language is Russian.  

Set Dictionary 
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1. Under Dictionaries, click Add, and browse to 
c:\development\MultiFile\Frost.sdt. Select the dictionary and click Open.  

Switch Projects 

1. Go to Options > Switch Project.  
2. Select Multi-Frost and click OK.  

Multiple Import Files 

1. Make sure that "Nothing_Gold.doc", "Fire_And_Ice.doc", and 
"Stopping_by_the_Woods.doc" are in the working directory. The only other file 
in the working directory should be "Frost.sdt".  

2. Click the folder button on Select the files to import and select the working 
folder.  

3. Fill the import dialog out as follows:  
4.   Select files to import 
5.   c:\development\MultiFile\*.doc 
6.   [ ] include subdirectories 
7.  
8.   Select location to save imported files 
9.   [x]  save an import log 
10.   multi.log 
11.  
12.   Select Actions 
13.   [x] Filter: Microsoft Word 2003 
14.   [ ] Convert encoding from LATIN1 
15.   [x] Segment: Word2003, by sentences 
16.   [x] Pretranslate 
17.   [ ] Extract: create extract file(extract.fff) 
18.    
19.   [ ] Enable Multi-Language Import 

20. Press the import button, and wait for the import to complete.  
21. Verify that the following files have been created (all should be in the working 

directory):  
o Nothing_Gold_en.fff, Nothing_Gold_ru.fff, Nothing_Gold.cod  
o Fire_And_Ice_en.fff, Fire_And_Ice_ru.fff, Fire_And_Ice.cod  
o Stopping_by_the_Woods_en.fff, Stopping_by_the_Woods_ru.fff, 

Stopping_by_the_Woods.cod  
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o assoref_en.fff, assoref_ru.fff  
o multi.log.  

The only additional files should be the original Nothing_Gold.doc, 
Fire_And_Ice.doc,and Stopping_by_the_Woods.doc. Any missing or other 
additional files indicate a bug.  

22. Click OK and close the Fortis Import dialog.  

Open Multiple Language Pairs in Global View Only 

1. Open the Open Language Pair dialog.  
2. Hold down the CTRL button and click on the three files you just imported.  
3. Click Open.  
4. A window will appear that offers you the choice to open these language pairs in 

Separate View or Global View. Select Global View.  

N.B. Global View opens multiple files into one set of windows. You will scroll down to 
view the separate files. The segment numbers will reset with each file and when you save 
the files, they will save to their individual locations. Global view is for ease of use when 
you are dealing with many separate files pairs.  

Start The Fuzzy Network In Global View 

1. Press ALT+ENTER to start the fuzzy engine in Global View.  

Filter Segment Options 

Modify Source Text 

Recount Segments 

Save File While Segments Filtered 

Close All Files 
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Open Files in Global View 

Show Hidden Text 

Unprotect/Restore Source Text 

Extract New Terminology 

Insert Translations from Glossary 

1. Activate segment ten. Four glossary entries should show up in the Dictionary 
window. Words in the editor that have counterparts in the dictionary are 
displayed in red.  

2. Put your cursor in the word 'Between' in the Target window.  
3. Press ALT+T. 'Между' will be inserted in place of 'Between'.  
4. Do the same for 'woods'.  
5. Put your cursor in the word 'frozen' and use Terminology > Translate Term 

to insert the term from the dictionary.  
6. Do the same for 'lake'.  

Close All Files 

Close all files using one of the following two methods:  

1. Click the Close All Files toolbar button to close all of the files open in Global 
View.  

2. The other option to close all files is to use File > Close All from the menu bar.  

N.B. Clicking the 'X' button in the top-right corner of the Global View windows will not 
close the files. It will only minimize the Global View windows. If you want to open any of 
the already-opened files in Separate View, you need to first close all of the files using one 
of the two methods explained above.  

Open Multiple Language Pairs In Separate View 
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1. Go to File > Open Language Pair. The Open Language Pair window should 
open to the working folder.  

2. Choose all three of the files to open, and click Open.  
3. Choose to open the files in Separate View. The files will each open in their own 

set of editor windows.  

List Language Pairs 

1. Click Window > List Language Pairs. This will display a list of all of the open 
language pairs.  

2. Select Nothing_Gold_ru.fff and click OK.  

Previous Language Pair 

1. Click Window > Previous Language Pair.  
2. Do the same thing two more times. You should be back at the beginning file. 

(Need to fix bug to give file names of files user should see)  

Next Language Pair 

1. Click Window > Next Language Pair.  
2. (Need bug fix to accurately describe following actions)  

Multiple Export Files 

1. Click File > Export Documents.  
2. Select the folder button under Select files to export.  
3. Select c:\development\Multifile for Select location to save exported 

files.  
4. Click Export and wait for the export to finish.  
5. The export log will not report statistics the same way that the import log did. You 

will see Task Complete at the top of the dialog.  
6. Open a Windows Explorer window and browse to c:\develop\MultiFile. Check 

to make sure that the exported files (the _ru.doc files) have a file size greater 
than 0 KB. They should be around 18 KB per file. Open each of the files and 
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compare it with the original English file. Formatting differences are a bug and 
should be reported, along with copies of the files.  

If you have trouble exporting, see our FAQ page for help troubleshooting the problem.  

Close All Files 

1. Use the Close All Files toolbar button to close all of the open files.  

Recursive Scenario mirroring directory structure 

Reset Fuzzy Threshold Value to 30% 

(waiting for a bug fix to enable this feature.)  

Recursive Import Files mirroring directory Structure 

1. Set the working directory to c:\development\Recursive  
2. Check to make sure that Nothing_Gold.doc is in c:\development 

Recursive\shallow, Fire_and_Ice.doc is in 
c:\development\Recursive\shallow\medium, and 
Stopping_by_the_Woods.doc is in 
c:\development\Recursive\shallow\medium\deep. Any extra or missing 
files may indicate a bug and should be reported to the development team.  

3. Open the Import dialog.  
4. Click the folder button under Select files to import.  
5. Select c:\development\Recursive and click OK. The file path will have *.doc 

at the end, indicating all of the files with the .doc extension.  
6. Check the Include Subdirectories button.  
7. The import dialog should be filled out as follows:  
8.   Select the files to import  
9.   c:\development\Recursive\*.doc 
10.   [x] include subdirectories 
11.    
12.   Select location to save imported files 
13.   [x]  save an import log:  
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14.   mirror.log 
15.              
16.   Select Actions  
17.   [x] Filter: Microsoft Word 2003 
18.   [ ] Convert encoding from LATIN1 
19.   [x] Segment: Word2003, by sentences 
20.   [x] Pretranslate 
21.   [x] Extract 
22.    
23.   [ ] Enable Multi-Language Import 

24. Press the import button and wait for the import to complete.  
25. Verify that the following files have been created (directory listed before each file 

set): 

c:\development\Recursive  

o recursive.log  
o assoref_en.fff, assoref_ru.fff  
o extract_en.fff, extract_ru.fff  

c:\development\Recursive\shallow  

o Nothing_Gold_en.fff, Nothing_Gold_ru.fff, Nothing_Gold.cod  

c:\development\Recursive\shallow\medium  

o Fire_and_Ice_en.fff, Fire_and_Ice_ru.fff, Fire_and_Ice.cod  

c:\development\Recursive\shallow\medium\deep  

o Stopping_by_the_Woods_en.fff, Stopping_by_the_Woods_ru.fff 
Stopping_by_the_Woods.cod  

 

26. The only other files should be the original *.doc files. Any other files, or missing 
files indicate a bug.  
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Recursive Import with alternative output folder 

1. Set the working directory to c:\development\Recursive  
2. Check to make sure that Nothing_Gold.doc is in c:\development 

Recursive\shallow, Fire_and_Ice.doc is in 
c:\development\Recursive\shallow\medium, and 
Stopping_by_the_Woods.doc is in 
c:\development\Recursive\shallow\medium\deep. Any extra or missing 
files may indicate a bug and should be reported to the development team.  

3. Open the Import dialog.  
4. Click the folder button under Select files to import.  
5. Select c:\development\Recursive and click OK. The file path will have *.doc 

at the end, indicating all of the files with the .doc extension.  
6. Check the Include Subdirectories button.  
7. Click the folder button under Select the files to import.  
8. Select c:\development and click Make New Folder.  
9. Name the new folder "Recursive Output" and click OK.  
10. The import dialog should be filled out as follows:  
11.   Select the files to import  
12.   c:\development\Recursive\*.doc 
13.   [x] include subdirectories 
14.    
15.   Select location to save imported files 
16.   c:\development\Recursive Output 
17.   [x]  save an import log:  
18.   mirror.log 
19.              
20.   Select Actions  
21.   [x] Filter: Microsoft Word 2003 
22.   [ ] Convert encoding from LATIN1 
23.   [x] Segment: Word2003, by sentences 
24.   [x] Pretranslate 
25.   [x] Extract 
26.    
27.   [ ] Enable Multi-Language Import 

28. Press the import button and wait for the import to complete.  
29. Verify that the following files have been created (directory listed before each file 

set): 
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c:\development\Recursive  

o recursive.log  
o assoref_en.fff, assoref_ru.fff  
o extract_en.fff, extract_ru.fff  

c:\development\Recursive Output\shallow  

o Nothing_Gold_en.fff, Nothing_Gold_ru.fff, Nothing_Gold.cod  

c:\development\Recursive Output\shallow\medium  

o Fire_and_Ice_en.fff, Fire_and_Ice_ru.fff, Fire_and_Ice.cod  

c:\development\Recursive Output\shallow\medium\deep  

o Stopping_by_the_Woods_en.fff, Stopping_by_the_Woods_ru.fff 
Stopping_by_the_Woods.cod  

 

30. There should be no other files in the output folders. Any extra files, or missing 
files indicate a bug.  

Recursive Export Files 

1. Open the Export dialog.  
2. Under Select files to export click the folder button.  
3. Set this folder to c:\development\Recursive Output.  
4. Check the Include Subdirectories box.  
5. Set c:\development\Recursive Output in Set location to save exported 

files.  
6. Click the export button and wait for the export to finish.  
7. Check the Recursive Output folder and make sure that the following files have 

been created: 
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c:\development\Recursive Output  

o Nothing_Gold_ru.doc  
o Fire_and_Ice_ru.doc  
o Stopping_by_the_Woods_ru.doc  

 

8. Any missing or additional files may indicate a bug, and should be reported.  

Multi-Language Scenario 

Simple Multi-Language Import 

1. Set the working directory to c:\development\MultiLang  
2. Fill the import dialog out as follows:  
3.   Select files to import 
4.   c:\development\MultiLang\*.doc 
5.   [x] include subdirectories 
6.    
7.   Select location to save imported files 
8.   c:\development\MultiLang 
9.   [x]  save an import log 
10.   mlang.log 
11.    
12.   Select Actions:  
13.   [x] Filter: Microsoft Word 2003 
14.   [ ] Convert encoding from LATIN1 
15.   [x] Segment: Word2003, by sentences 
16.   [x] Pretranslate 
17.   [ ] Extract: create extract file (extract.fff) 
18.    
19.   [x] Enable Multi-Language Imports 
20.   Selected Languages: zh-tw, zh-cn, fr-fr, ja-jp, ru-ru 

21. Press the import button, and wait for the import to complete.  
22. Verify that the following files have been created: 
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c:\development\MultiLang  

o mlang.log  
o assoref_en.fff, ..._fr.fff, ..._ja.fff, ..._zh.fff,  

c:\development\MultiLang\shallow  

o Nothing_Gold_en.fff, ..._fr.fff, ..._ja.fff, ..._zh.fff, Nothing_Gold.cod  

c:\development\MultiLang\shallow\medium  

o Fire_and_Ice_en.fff, ..._fr.fff, ..._ja.fff, ..._zh.fff, Fire_and_Ice.cod  

c:\development\MultiLang\shallow\medium\deep  

o Stopping_by_the_Woods_en.fff, ..._fr.fff, ..._ja.fff, ..._zh.fff, 
Stopping_by_the_Woods.cod  

23. The only additional files should be the original .doc files in their respective 
directories. Any missing or other additional files indicate a bug. (N.B. Multi-
Language Importing will override the target language you have selected in your 
Project Settings. If you want to import the language you have specified in Project 
Settings, you must include it in the Multi-Language import list.)  

Simple Multi-Language Import, with alternative output folder 

1. Set the working directory to: c:\development\MultiLang  
2. Create a folder in c:\development\ named MLang Output. We will use this 

directory as an alternative output folder.  
3. Fill the import dialog out as follows:  
4.   Select files to import 
5.   c:\development\MultiLang\*.doc 
6.   [x] include subdirectories 
7.    
8.   Select location to save imported files 
9.   c:\development\MultiLang\MLang Output 
10.   [x]  save an import log 
11.   mlang.log 
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12.    
13.   Select Actions:  
14.   [x] Filter: Microsoft Word 2003 
15.   [ ] Convert encoding from LATIN1 
16.   [x] Segment: Word2003, by sentences 
17.   [x] Pretranslate 
18.   [ ] Extract: create extract file (extract.fff) 
19.    
20.   [x] Enable Multi-Language Imports 
21.   Selected Languages: zh-tw, zh-cn, fr-fr, ja-jp, ru-ru 

22. Press the import button, and wait for the import to complete.  
23. Verify that the following files have been created: 

c:\development\MultiLang\MLang Output  

o mlang.log  
o assoref_en.fff, ..._fr.fff, ..._ja.fff, ..._zh.fff,  

c:\development\MultiLang\MLang Output\shallow  

o Nothing_Gold_en.fff, ..._fr.fff, ..._ja.fff, ..._zh.fff, Nothing_Gold.cod  

c:\development\MultiLang\MLang Output\shallow\medium  

o Fire_and_Ice_en.fff, ..._fr.fff, ..._ja.fff, ..._zh.fff, Fire_and_Ice.cod  

c:\development\MultiLang\MLang Output\shallow\medium\deep  

o Stopping_by_the_Woods_en.fff, ..._fr.fff, ..._ja.fff, ..._zh.fff, 
Stopping_by_the_Woods.cod  

 

24. The only additional files should be the original .doc files in their respective 
directories. Any missing or other additional files indicate a bug. 

(N.B. Multi-Language Importing will override the target language you have 
selected in your Project Settings. If you want to import the language you have 
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specified in Project Settings, you must include it in the Multi-Language import 
list.)  

Multi-Language Export 

1. Open the Export dialog.  
2. Under Select files to export click the folder button.  
3. Set this folder to c:\development\MultiLang\MLang Output.  
4. Check the Include Subdirectories box.  
5. Set c:\development\MultiLang in Set location to save exported files.  
6. Click the export button and wait for the export to finish.  
7. Check the MultiLang folder and make sure that the following files have been 

created: 

 
c:\development\MultiLang  

o Nothing_Gold_ja.doc, ..._fr.doc, ..._zh.doc  
o Fire_and_Ice_ja.doc, ..._fr.doc, ..._zh.doc  
o Stopping_by_the_Woods_ja.doc, ..._fr.doc, ..._zh.doc  

 

8. Verify that the finished files look like the originals, and are free of errors.  
9. Any missing or additional files may indicate a bug, and should be reported.  
10. For problems, consult our FAQ page, or log a bug on the Multiling Trac system.  

 

Working with Regular Expressions 

Creating Regular Expressions 

Segmentation Rules 
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Segmentation Exceptions 

Find all email addresses in document 

Find all email addresses containing a particular provider’s name 

Hide and View Segments using regular expressions 

Retrieved from 
http://starfish.multiling.com/wiki/index.php/Fortis_Test_Protocols 

Access the Fortis Revolution development wiki at 
http://starfish.multiling.com 
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Fortis Revolution Test Protocols Change Log 
 
As Fortis Revolution undergoes revisions and updates, the 
protocols must also be updated to reflect the current organization 
of the program. We have, therefore, included a summary of the 
protocol changes from one version of the protocols manual to the 
next. 
 
Updates since v 1.0 
 

• Profile Settings protocols reflects current tab organization 
• File paths revised 

• Simple Import protocol clarified 
 


